M02 SMS 1D Results

From Tuflow
Jump to: navigation, search

    Introduction

    TUFLOW has several kinds of output. All the output data is found in a folder named results under the TUFLOW folder. Each file begins with the name of the simulation which generated the files. The files which have “_1d” after the simulation name are results for the 1D portions of the model. We will look at the maximums (flow, level and velocity) as well as the time-series data. These are described separately in the sections below.

    Maximums

    1. From the TUFLOW\results\ folder open the following files:
      • M02_5m_001_1d_mmH_P.mif
      • M02_5m_001_1d_mmQ_P.mif
      • M02_5m_001_1d_mmV_P.mif
      These files contain the maximum and minimum values of water level (mmH), flow (mmQ) and velocity (mmV).
    2. Navigate to one of the culvert locations.
    3. At both ends of the culverts there is a point which contains the water level results, at the channel centre are points giving the flow and velocity results. Use the info tool to interrogate the results. The following information is displayed for the water level results:
      • Node ID (Node)
      • Maximum Water Level (Hmax)
      • Minimum Water Level (Hmin)
      • Time of max water level (tHmax)
      • Time of min water level (tHmin)
      • Change in water level from upstream node (dH)
      The last field is very useful for quality checking results with large 1D networks and will be used more in later modules.
      SMS H info.jpg


    Time-series

    In addition to the 1D solution files, the results folder contains a .2dm, .mat, .sup, and several .dat files. These are SMS files which contain a 2D mesh and accompanying solutions. To view the solution files from with SMS:

    1. Select File->Open from the menu bar. Open the Results folder from the TUFLOW directory.
    2. Locate the M02_5m_001.xmdf.sup file and open it. The TUFLOW output is read into SMS in the form of a two-dimensional mesh.
    3. From the project explorer, turn off all Map Data, Scatter Data, and Cartesian Grid Data. Turn on and highlight the Mesh Data.
    4. Open the Display Options dialog. From the 2D Mesh tab, turn on elements, contours and vectors.
    5. Switch to the Contour Options tab and select Color Fill as the contour method.
    6. Click OK to close the Display Options dialog.
    7. The mesh will be contoured according to the selected dataset and time step.
    8. SMS mod2 time series.jpg

    Conclusion

    SMS has been used to review the GIS outputs for the 1D culvert results. Return to the module 2 page, where the next step is to view the results in Excel.