Tutorial M02 001 GIS Inputs QGIS

From Tuflow
Jump to: navigation, search

Introduction

QGIS is used to create, import and view input data.

TUFLOW Project Re-Configuration

Re-configure the TUFLOW project to use and save empty files to the correct folder:

  1. Go to Plugins > TUFLOW > Editing > Configure / Create TUFLOW Project.
  2. Change the folder which contains TUFLOW to the Module_02 folder. This is the only change required, the model folder structure and template empty files are supplied from previous model.
    Note: The 'results' and 'check' folder get automatically created when the TUFLOW model is run.
  3. Click 'OK' and save the QGIS workspace by selecting Project > Save As.

    M02 Configure Project.png

  4. Set the QGIS workspace projection to EPSG:32760, see Set the Projection.


Method

Navigate to the Module_02\Tutorial_Data folder. Copy the below GIS files into the Module_02\TUFLOW\model\gis folder:

  • 2d_zsh_M02_rd_crest_001_L
  • 2d_zsh_M02_rd_crest_001_P

Investigate the supplied files:

  1. Open the files, either:
    • Drag and drop all .shp files into the QGIS workspace, or
    • Select Layer > Add layer > Add Vector Layer and navigate to the Module_02\TUFLOW\model\gis folder.
  2. The 2d_zsh line layer represents the breaklines:
    • No ‘Z’ attribute is specified, the elevations are taken from the 2d_zsh point layer.
    • The breakline on the north side has the same Shape_Width as the cell size, this is a thick breakline modifying whole cells. The other two breaklines don't have the attribute specified, these are thin breaklines modifying only the cell sides and cell corners.
    • The Shape_Option of 'MAX' is specified for all breaklines. The Zpt elevations only changes when the Z shape elevation at the Zpt is higher. The purpose of the Z shape is to enforce the highest elevations along the road crest.

    Animation M02 GIS 001 01.gif

  3. The 2d_zsh point layer is used to apply elevation to the breaklines:
    • The values in the 'Z' attribute are elevations above datum assigned to each point. The elevations are being interpolated along the breakline.
    • The points must be snapped to the vertices of the 2d_zsh line to instruct TUFLOW that these layers are linked. If no points are in the layer, the elevation on the line object is used, i.e. the elevation along the line does not vary. For more information, see Table 6-8 of the 2018 TUFLOW Manual.

    Animation M02 GIS 001 02.gif


Creating Breaklines (Optional)

Breaklines are provided for this tutorial, however, these could be made using the breakline flag with the asc_to_asc utility which extracts elevations from a DEM for breaklines in the 2d_zsh format. The utility is provided in the exe/asc_to_asc folder. It can also be downloaded from the TUFLOW website and saved into a folder with other utilities.

  1. Create a new folder called Data_Processing in the Module_02 folder.
  2. Use the 'Import Empty' tool to create a new 2d_zsh layer called ‘breaklines’ as a ‘line’ type and save it in the Data_Processing folder.
  3. Digitise a line using the ‘Add Line Feature’ button following the road crest. This could match the provided breaklines or be an section of road not covered by the original breakline.
  4. Enter the following attributes and save the file:
    • Z: Null
    • dZ: 30
    • Shape_Width: 5
    • Shape_Option: Max
  5. Create a new batch file _run_M02_asc_to_asc_Breaklines.bat in the Module_02\Data_Processing folder and open it in a text editor.
  6. Input the following (Note: Utility location may differ):
    set asc_to_asc="C:\TUFLOW\Utilities\asc_to_asc\asc_to_asc_w64.exe"
  7. Use the -brkline flag to call the breakline function. The utility then expects the 2d_zsh_breaklines layer and the DEM.
    %asc_to_asc% -brkline 2d_zsh_breaklines_L.shp ..\Module_02\TUFLOW\model\grids\DEM.flt
  8. Save the batch file and double click it in file explorer to run the utility.
  9. The utility creates a points layer and updates the lines layer. These layers can be copied into the Module_02\TUFLOW\model\gis folder and read into the TGC.


Conclusion

  • Two 2d_zsh layers were inspected to enforce the breaklines in the model.


Up
Go-up.png Back to Module 2 Main Page