Tutorial M04 GIS Inputs QGIS

From Tuflow
Jump to: navigation, search

Introduction

QGIS is used to create, import and view input data.

TUFLOW Project Re-Configuration

Re-configure the TUFLOW project to use and save empty files to the correct folder:

  1. Go to Plugins > TUFLOW > Editing > Configure / Create TUFLOW Project.
  2. Change the folder which contains TUFLOW to the Module_04 folder. This is the only change required, the model folder structure and template empty files are supplied from previous model.
    Note: The 'results' and 'check' folder get automatically created when the TUFLOW model is run.
  3. Click 'OK' and save the QGIS workspace by selecting Project > Save As.

    M04 Configure Project.png

  4. Set the QGIS workspace projection to EPSG:32760, see Set the Projection.


Method

Navigate to the Module_04\Tutorial_Data folder. Copy and save all the below layers into the Module_04\TUFLOW\model\gis folder:

  • 2d_lfcsh_M04_bridge_001_L
  • 2d_po_M04_001_L
  • 2d_po_M04_001_P
  • 2d_zsh_M02_cut_002_R

Investigate the supplied files:

  1. Open the files, either:
    • Drag and drop the .shp files into the QGIS workspace, or
    • Select Layer > Add layer > Add Vector Layer and navigate to the Module_04\TUFLOW\model\gis folder.
  2. The 2d_zsh file cuts through the road embankment, see Module 2 for more information.
  3. The 2d_lfcsh represents the bridge in 2D, it has layers of varying blockage and form loss for piers, bridge deck and railings. The layers of the bridge structure are defined as:
      M04 bridge layers 01.png
    • Layer 1: Beneath the bridge deck.
    • Layer 2: The bridge deck.
    • Layer 3: The bridge rails.
    • Layer 4: Flow above the rails (assumed to be unimpeded).

    See Table 6-21 of the 2018 TUFLOW Manual for more information on the attributes.

    Animation M04 GIS 01a.gif

  4. The 2d_po files include a structure group output for the 2D bridge. The 'Label' attribute links the 2d_po line to the 2d_po points by the same attribute ‘Bridge’.
  5. The 2d_po line is snapped to the 2d_lfcsh from left to right looking downstream and has the following attributes:
    • Type = QS (structure flow)
    • Label = Bridge
  6. The 2d_po points are digitised upstream and downstream of the 2d_lfcsh and have the following attributes:
    • Type = HU (water level upstream) and HD (water level downstream)
    • Label = Bridge

    Animation M04 GIS 02a.gif


Conclusion

  • The 2d_lfcsh layer was supplied for use as a 2D bridge.
  • The 2d_po structure group layers were added to output additional hydraulic information of the 2D bridge.


Up
Go-up.png Back to Module 4 Main Page