Tutorial M05 GIS Inputs QGIS

From Tuflow
Jump to: navigation, search

Introduction

QGIS is used to create, import and view input data.

TUFLOW Project Re-Configuration

Re-configure the TUFLOW project to use and save empty files to the correct folder:

  1. Go to Plugins > TUFLOW > Editing > Configure / Create TUFLOW Project.
  2. Change the folder which contains TUFLOW to the Module_05 folder. This is the only change required, the model folder structure and template empty files are supplied from previous model.
    Note: The 'results' and 'check' folder get automatically created when the TUFLOW model is run.
  3. Click 'OK' and save the QGIS workspace by selecting Project > Save As.

    M05 Configure Project.png

  4. Set the QGIS workspace projection to EPSG:32760, see Set the Projection.


Method

Navigate to the Module_05\Tutorial_Data folder. Copy and save all the below layers into the Module_05\TUFLOW\model\gis folder:

  • 1d_nwk_M05_pipes_001_L
  • 1d_nwk_M05_pits_001_P
  • 2d_sa_M05_001_R
  • 2d_zsh_M02_landscape_002_L
  • 2d_zsh_M02_landscape_002_P
  • 2d_zsh_M02_landscape_002_R

Investigate the supplied files:

  1. Open the files, either:
    • Drag and drop all .shp files into the QGIS workspace, or
    • Select Layer > Add layer > Add Vector Layer and navigate to the Module_05\TUFLOW\model\gis folder.
  2. The 2d_zsh landscape files create a TIN elevation footprint of the development, see Module 2 for more information.
  3. The 1d_nwk layers represents pits and pipes. The pipes are a series of circular culverts with a set Manning’s roughness value. The pits are set up as a series of Q type pits to convey flow into the pipe network via SX connections. See Section 5.4 of the 2018 TUFLOW Manual for more information on the attributes.

Create outlet from the 1D pipe network into the 2D domain with the TUFLOW plugin:

  1. It is recommended to have a grd_check file from a previous run (with the same model cell size) turned on when digitising SX lines as the number of cells selected must correspond to the dimensions of the 1D structure. In this module, the outlet pipe has a diameter of 0.9m, only one cell is selected.
  2. Click on the ‘Import Empty File’ symbol from the TUFLOW plugin toolbar.
  3. Select '2d_bc' from the Empty Type list.
  4. In the Run ID box write 'M05_outlet_001'.
  5. Tick the 'Lines' Geometry Type and hit 'OK'. The 2d_bc layer appears in the QGIS Layers panel.
  6. Digitise a CN (connecting) line from the downstream pipe and a SX line to allow flow to transfer from 1D to 2D.
  7. Right click on the ‘2d_bc_M05_outlet_001_L’ and toggle on Editing.
  8. Select 'Add Line Feature' and digitise a line snapped from the downstream of the pipe.
  9. Terminate the line by right clicking and write 'CN' into the 'Type' attribute.
  10. Add another line snapped to the end of the CN line and enter 'SX' as the 'Type' attribute.
  11. Turn off editing to save the edits.

    Animation M05 GIS 01d.gif

Investigate the supplied inflows:

  1. The 2d_sa layer contains four regions, each with a different name attribute to apply unique inflows to different parts of the development site:

    Animation M05 GIS 02d.gif


Conclusion

  • The 1d_nwk pipes and pits files were supplied and investigated.
  • An outlet from the pipe network was digitised downstream of the road as 2d_bc.
  • The 2d_sa files were supplied to apply inflow directly to the pits.


Up
Go-up.png Back to Module 5 Main Page